黑龙江大学论坛|黑土地

 找回密码
 开放注册
搜索
查看: 17597|回复: 3
打印 上一主题 下一主题

[软件] 单臂路由/PPPoE/PPPoA配置实例

[复制链接]
跳转到指定楼层
1#
发表于 2012-2-7 18:36:51 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
交换机配置
  3512xl#show running-config
  Building configuration...
  
  Current configuration:
  
  !
  version 12.0
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname 3512xl
  !
  no logging console
  enable password mysecret
  !
  !
  !
  !
  !
  ip subnet-zero
  !
  !
  !
  interface FastEthernet0/1
  switchport mode trunk
  !
  
  !-- If 802.1Q is configured,
  !-- you will instead see the following output
  !-- under interface FastEthernet0/1:
  !-- interface FastEthernet0/1
  !-- switchport trunk encapsulation dot1q
  !-- switchport mode trunk
  
  !
  interface FastEthernet0/2
  switchport access vlan 2
  spanning-tree portfast
  !
  interface FastEthernet0/3
  spanning-tree portfast
  !
  interface FastEthernet0/4
  !
  interface FastEthernet0/5
  !
  interface FastEthernet0/6
  !
  interface FastEthernet0/7
  !
  interface FastEthernet0/8
  !
  interface FastEthernet0/9
  !
  interface FastEthernet0/10
  !
  interface FastEthernet0/11
  !
  interface FastEthernet0/12
  !
  interface GigabitEthernet0/1
  !
  interface GigabitEthernet0/2
  !
  interface VLAN1
  ip address 10.10.10.2 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
  !
  ip default-gateway 10.10.10.1
  !
  line con 0
  transport input none
  stopbits 1
  line vty 0 4
  password mysecret
  login
  line vty 5 15
  login
  !
  end
  
  路由器配置
  
  Current configuration:
  !
  version 12.1
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname c2600
  !
  no logging console
  enable password mysecret
  !
  !
  !
  !
  !
  ip subnet-zero
  !
  !
  !
  !
  !
  !
  !
  !
  !
  !
  interface FastEthernet0/0
  no ip address
  duplex auto
  speed auto
  !
  interface FastEthernet0/0.1
  encapsulation isl 1
  ip address 10.10.10.1 255.255.255.0
  no ip redirects
  !
  
  !-- If 802.1Q is configured,
  !-- you will instead see the following output
  !-- under interface FastEthernet0/0.1:
  !-- interface FastEthernet0/0.1
  !-- encapsulation dot1Q 1 native
  !-- ip address 10.10.10.1 255.255.255.0
  
  !
  !
  interface FastEthernet0/0.2
  encapsulation isl 2
  ip address 10.10.11.1 255.255.255.0
  no ip redirects
  !
  
  !-- If 802.1Q is configured,
  !-- you will instead see the following output
  !-- under interface FastEthernet0/0.2:
  !-- interface FastEthernet0/0.2
  !-- encapsulation dot1Q 2
  !-- ip address 10.10.11.1 255.255.255.0
  
  !
  interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
  !
  ip classless
  no ip http server
  !
  !
  !
  line con 0
  transport input none
  line aux 0
  line vty 0 4
  password mysecret
  login
  !
  no scheduler allocate
  end
  
  PPPoE配置实例(2600路由器接ADSL Modem)
  
[[The No.2 Picture.]]

  hostname pooh
  ip host rund 172.17.247.195
  !
  ip subnet-zero
  no ip domain-lookup
  !
  vpdn enable
  no vpdn logging
  !
  vpdn-group 1
  request-dialin
  protocol pppoe
  !
  !
  !
  !
  interface Ethernet0/0
  ip address 10.200.56.22 255.255.255.0
  ip nat inside
  no ip mroute-cache
  !
  !
  !
  !
  interface Ethernet0/1
  no ip address
  pppoe enable
  pppoe-client dial-pool-number 1
  !
  interface Dialer1
  ip address negotiated
  ip nat outside
  ip mtu 1492
  encapsulation ppp
  no ip mroute-cache
  dialer pool 1
  dialer-group 1
  ppp authentication pap
  ppp pap sent-username cisco password cisco1
  !
  ip classless
  no ip http server
  !
  dialer-list 1 protocol ip permit
  ip nat inside source list 1 interface Dialer1 overload
  ip route 0.0.0.0 0.0.0.0 dialer1
  access-list 1 permit 10.200.56.0 0.0.0.255
  !
  line con 0
  exec-timeout 0 0
  transport input none
  line vty 0 4
  login
  password ww
  !
  end
  
  PPPoA配置实例 (2600路由器连接Wic-1ADSL)
  
  vpdn enable
  no vpdn logging
  
  !--- default.
  
  !
  vpdn-group pppoe
  request-dialin
  
  !--- we are the PPPoE client requesting to establish
  !--- a session with the aggregation unit (6400 NRP).
  
  protocol pppoe
  !
  
  
  !--- internal Ethernet network.
  
  !
  interface FastEthernet0
  ip address 10.92.1.182 255.255.255.0
  ip nat inside
  
  
  !--- DSL interface.
  
  !
  interface ATM0
  no ip address
  no atm ilmi-keepalive
  bundle-enable
  dsl operating-mode auto
  hold-queue 224 in
  
  !--- All defaults.
  
  !--- PPPoE runs on top of AAL5SNAP, but the
  !--- encap aal5snap command is not used.
  
  !
  interface ATM0.1 point-to-point
  pvc 1/1
  pppoe-client dial-pool-number 1
  
  !--- pvc 1/1 is an example value that must be changed
  !--- to match the value used by the ISP.
  
  !
  
  !--- The PPPoE client code ties into a dialer interface upon
  !--- which a virtual-access interface is cloned.
  
  !
  interface Dialer1
  ip address negotiated
  ip mtu 1492
  
  !--- Ethernet MTU default = 1500 (1492 + PPPoE headers = 1500)
  
  ip nat outside
  encapsulation ppp
  dialer pool 1
  
  !--- Ties to atm interface.
  
  ppp authentication chap callin
  ppp chap hostname
  ppp chap password
  !
  
  !--- The ISP will instruct you regarding
  !--- the type of authentication to use.
  !--- To change from PPP CHAP to PPP PAP,
  !--- replace the following three lines:
  !--- ppp authentication chap callin
  !--- ppp chap hostname
  !--- ppp chap password
  !--- with the following two lines:
  !--- ppp authentication pap callin
  !--- ppp pap sent-username password
  
  !--- For NAT we are going to overload on the Dialer1
  !--- interface and add a default route out
  !--- since dialer ip address can change.
  
  ip nat inside source list 1 interface Dialer1 overload
  ip classless
  ip route 0.0.0.0 0.0.0.0 dialer1
  no ip http server
  !
  access-list 1 permit 10.92.1.0 0.0.0.255
2#
发表于 2012-2-8 03:46:27 | 只看该作者
曾经潜水无算,最后记得起来冒泡。
3#
发表于 2012-2-8 12:53:00 | 只看该作者
没人搭理,偶来也~~~~~顶一下,写的不错学习中
4#
发表于 2012-2-8 22:00:01 | 只看该作者
仔细读着。。。(*^__^*不得不赞一个。
您需要登录后才可以回帖 登录 | 开放注册

本版积分规则

手机访问本页请
扫描左边二维码
         本网站声明
本网站所有内容为网友上传,若存在版权问题或是相关责任请联系站长!
站长电话:0898-66661599    站长联系QQ:7123767   
         站长微信:7123767
请扫描右边二维码
www.jtche.com

小黑屋|手机版|Archiver|黑龙江大学论坛 ( 琼ICP备10001196号-2 )

GMT+8, 2024-5-12 21:52 , Processed in 0.041575 second(s), 14 queries .

Powered by 校园招聘信息

© 2001-2020 黑龙江大学论坛校园招聘

快速回复 返回顶部 返回列表